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Legal Notices

This Documentation, which includes embedded help systems and electronically distributed 
materials (hereinafter referred to as the “Documentation”), is for your informational pur-
poses only and is subject to change or withdrawal by Quest Software, Inc and/or its affiliates 
at any time. This Documentation is proprietary information of Quest Software, Inc and/or its 
affiliates and may not be copied, transferred, reproduced, disclosed, modified or duplicated, 
in whole or in part, without the prior written consent of Quest Software, Inc and/or its affil-
iates  

If you are a licensed user of the software product(s) addressed in the Documentation, you 
may print or otherwise make available a reasonable number of copies of the Documentation 
for internal use by you and your employees in connection with that software, provided that 
all Quest Software, Inc and/or its affiliates copyright notices and legends are affixed to each 
reproduced copy. 

The right to print or otherwise make available copies of the Documentation is limited to the 
period during which the applicable license for such software remains in full force and effect. 
Should the license terminate for any reason, it is your responsibility to certify in writing to 
Quest Software, Inc and/or its affiliates that all copies and partial copies of the Docu-
mentation have been returned to Quest Software, Inc and/or its affiliates or destroyed. 

TO THE EXTENT PERMITTED BY APPLICABLE LAW, QUEST SOFTWARE, INC. PROVIDES THIS 
DOCUMENTATION “AS IS” WITHOUT WARRANTY OF ANY KIND, INCLUDING WITHOUT 
LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, OR NONINFRINGEMENT. IN NO EVENT WILL QUEST SOFTWARE, INC. BE LIABLE TO 
YOU OR ANY THIRD PARTY FOR ANY LOSS OR DAMAGE, DIRECT OR INDIRECT, FROM THE 
USE OF THIS DOCUMENTATION, INCLUDING WITHOUT LIMITATION, LOST PROFITS, LOST 
INVESTMENT, BUSINESS INTERRUPTION, GOODWILL, OR LOST DATA, EVEN IF QUEST 
SOFTWARE, INC. IS EXPRESSLY ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH LOSS OR 
DAMAGE. 

The use of any software product referenced in the Documentation is governed by the applic-
able license agreement and such license agreement is not modified in any way by the terms 
of this notice. 

The manufacturer of this Documentation is Quest Software, Inc and/or its affiliates.
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Provided with “Restricted Rights.” Use, duplication or disclosure by the United States 
Government is subject to the restrictions set forth in FAR Sections 12.212, 52.227-14, and 
52.227-19(c)(1) - (2) and DFARS Section 252.227-7014(b)(3), as applicable, or their suc-
cessors. 

Copyright © 2021 Quest Software, Inc and/or its affiliates All rights reserved. All trademarks, 
trade names, service marks, and logos referenced herein belong to their respective com-
panies. 



4

Contact erwin
Understanding your Support

Review support maintenance programs and offerings.

Registering for Support

Access the erwin support site and click Sign in or Sign up to register for product support.

Accessing Technical Support

For your convenience, erwin provides easy access to "One Stop" support for all editions of 
erwin Data Modeler, and includes the following:

Online and telephone contact information for technical assistance and customer ser-
vices 

Information about user communities and forums 

Product and documentation downloads  

erwin Support policies and guidelines  

Other helpful resources appropriate for your product  

For information about other erwin products, visit http://erwin.com/products.

Provide Feedback

If you have comments or questions, or feedback about erwin product documentation, you 
can send a message to techpubs@erwin.com.

erwin Data Modeler News and Events

Visit www.erwin.com to get up-to-date news, announcements, and events. View video 
demos and read up on customer success stories and articles by industry experts.

https://support.erwin.com/hc/en-us/articles/360035278592-erwin-Data-Modeler-Mart-Web-Portal-Technical-Support-Portal
https://support.erwin.com/hc/en-us
https://erwin.com/products/erwin-data-modeler/
http://erwin.com/products/
mailto:techpubs@erwin.com
http://erwin.com/
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Introduction

The Feature Tour guide walks Data Architects, Data Administrators, Application Admin-
istrators, Database Administrators, and Partners through the features introduced in erwin 
Data Modeler (DM) 2021 R1 release.

The features and enhancements introduced in this release are:

erwin Mart Administrator UI Facelift

NoSQL Modeling

JSON and AVRO Support

Oracle 12c R2, 18c,19c, and 21c 

Microsoft SQL Server 2019

Microsoft Azure SQL

MySQL 

Data Vault 2.0 Support

Productivity and UI Enhancements

Database Connectivity

For additional information about a feature, in erwin Data Modeler, click Help > Help Topics 
on the toolbar or press F1.
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erwin Mart Administrator UI Facelift

erwin Mart Administrator now comes with a brand new UI that follows Google’s Material 
Design principles. The redesigned UI offers an improved user experience with its modern 
look and feel, dark and light modes, and graphical buttons and icons.

Apart from the overall facelift, the wiki-like editable Home page lets you add information, 
such as key text, process diagrams, important hyperlinks, resources, and much more. Also, 
the configurable Dashboard let’s you add and view a pictorial presentation of your data and 
actions on the Mart. You can add charts for your data footprint, model overview and his-
tory, profile data, and session overview.

For more information, refer to the erwin Mart Online Help.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/Mart Online Help/Online Help.html
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NoSQL Modeling

Along with relational databases, erwin Data Modeler (DM) now supports the following 
NoSQL, non-relational databases as target databases:

MongoDB 4.x

Cassandra 3.x

Couchbase 6.x

These NoSQL databases support all the erwin DM features and functions. The following sec-
tions will take you through these features with MongoDB database as an example:

Migrating a relational model to NoSQL model

Reverse engineering models from database and script

Forward engineering models to database

Comparing changes using Complete Compare
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MongoDB Support

erwin Data Modeler (DM) now supports MongoDB 4.x as a target database. This imple-
mentation supports the following objects:

Databases

Collection

Collation

Index

Relationships

User IDs

Roles

View

The following table lists the supported data types:

Numeric String Lit-
erals

Date and Time Other

 l double

 l binary

 l int

 l integer

 l boolean

 l minKey

 l maxKey

 l long

 l decimal

 l string  l date

 l timestamp

 l object

 l array

 l null

 l objectId

 l regex

 l code

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/MongoDB_Support_Summary.html
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Cassandra Support

erwin Data Modeler (DM) now supports Cassandra 3.x/4.x as a target database. This imple-
mentation supports the following objects:

Aggregate

Function

Keyspace

Materialized View

Materialized View Column

Role

Table

Table Column

Index

User Type

The following table lists the supported data types:

Category Data Type Supported Constants

Native  l ascii

 l bigint

 l blob

 l boolean

 l counter

 l date

 l decimal

 l double

 l float

 l string

 l integer

 l blob

 l boolean

 l integer

 l integer, string

 l integer, float

 l integer, float

 l integer, float

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Cassandra_Support_Summary.html


12

 l inet

 l int

 l smallint

 l text

 l time

 l timestamp

 l timeuuid

 l tinyint

 l uuid

 l varint

 l string

 l integer

 l integer

 l string

 l integer, string

 l integer, string

 l uuid

 l integer

 l uuid

 l integer
Collection  l list

 l map

 l set

 

Tuple  l tuple  
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Couchbase Support 

erwin Data Modeler (DM) now supports Couchbase 6.x as a target database. This imple-
mentation supports the following objects:

Bucket

Document

Field

Full Text Index

Global Index

User ID

View

Following are the supported data types:

MISSING

NULL

BOOLEAN

NUMBER

STRING

ARRAY

OBJECT

BINARY

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Couchbase_Support_Summary.html
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Migrating Relational Models to NoSQL Models

You can convert and migrate your relational models to NoSQL models in two ways:

Changing the target database

Deriving a model

This topic walks you through the steps to migrate a SQL Server model to a MongoDB model. 
Similarly, you can migrate your relational models to Cassandra and Couchbase models.

Note: Ensure that you keep a backup of your original models.

Migration by Changing the Target Database

To migrate by changing the target database, follow these steps:

 1. Open your relational model in erwin Data Modeler (DM).
Note: Ensure that you are in the Physical mode.
For example, the following image uses the sample eMovies.erwin model. In the 
Objects Count pane, note the number of tables, columns, and relationships.
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 2. On the ribbon, click Actions > Target Database or on the status bar, click the database 
name.
The erwin Data Modeler -- Target Server screen appears.

 3. In the Database drop-down list, select MongoDB.
By default, the Auto Denormalization check box is selected. Keep it selected.

 4. Click OK.
The conversion process starts.
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Once the conversion is complete, the existing model in migrated to a NoSQL database.

In the Objects Count pane, note that instead of tables and columns, we now have col-
lections and fields. Also, the Relationships count has changed to 0. The migration pro-
cess converts and merges multiple tables, columns, and relationships to the NoSQL 
format according to the database that you select.                  

Note: This migration method overwrites the existing model once you save it. Hence, 
we recommend that you keep a backup of your original model.

Migration by Deriving a Model

To migrate by deriving a model, follow these steps:
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 1. Open your relational model in erwin Data Modeler (DM).
Note: Ensure that you are in the Physical mode.
For example, the following image uses the sample eMovies.erwin model. In the 
Objects Count pane, note the number of tables, columns, and relationships.

 2. On the  ribbon,  click Actions > Design Layers > Derive New Model.
The Derive Model screen appears. By default, the Source Model is set to your current 
model.
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 3. In the Database drop-down list, select MongoDB.
By default, the Auto Denormalization check box is selected. Keep it selected.
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 4. Click Next.
Note: If the Type Resolution screen appears, click Finish.
The Type Selection section appears.
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 5. Select the types of objects that you want to derive into the target MongoDB model.

 6. Click Next.
The Object Selection section appears. Based on the object types you selected in step 
5, it displays a list of objects.
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 7. Select the objects that you want to derive into the target MongoDB model.

 8. Click Derive.
The model derivation process starts.
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Once the conversion is complete, the existing model in migrated to a NoSQL database.

In the Objects Count pane, note that instead of tables and columns, we now have col-
lections and fields. Also, the Relationships count has changed to 0. The migration pro-
cess converts and merges multiple tables, columns, and relationships to the NoSQL 
format according to the database that you select. 
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Reverse Engineering Models

You can create a data model from a database or a script using the Reverse Engineering pro-
cess.

This topic walks you through the steps to reverse engineer a MongoDB model. Similarly, you 
can reverse engineer a model from your Cassandra Keyspace and Couchbase Bucket.

To reverse engineer a model:

 1. In erwin Data Modeler (DM), click Actions > Reverse Engineer.
The New Model screen appears.

 2. Click Logical/Physical and set Database to MongoDB.

 3. Click Next.
The Reverse Engineer Process Wizard appears.
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 4. Click one of the following options:

 l Database: Use this option to reverse engineer a model from your database.

 l Script File: Use this option to reverse engineer a model from a script. Selecting 
this option enables the File field. Click Browse and select the necessary script 
file.

Note: If you click Script File, jump to step 8 below and ensure that Document 
Count or Document % is not set to zero (0).

 5. Click Next.
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The Connection section appears. Use this section to connect to the database from 
which you want to reverse engineer the model. You can connect to the database dir-
ectly or using a connection string. The following table explains the connection para-
meters:

Connection 
Method

Parameters/Values

Connection 
String

Specify the MongoDB Connection String.
For example: mongodb+srv://<abcd>:****@<xyz>.mon-
godb.net/test?retryWrites=true&w=majority

Replace <abcd> with your username and <xyz> with host name. The host 
name parameter would change based on your MongoDB deployment; 
standalone, replica set, or a sharded cluster.

Direct
Specify the host name and port number of your 
MongoDB deployment. Also, specify the database that you want to con-
nect to.
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In the following image, for example, the connection is being established using a con-
nection string.

 6. Click Connect.
On successful connection, your connection information is displayed under Recent Con-
nections.

 7. Click Next.
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The Database section appears. It displays a list of available databases.

 8. Under Available Databases, select the databases that you want to reverse engineer. 
Then, click . 
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This moves the selected databases under Selected Databases.

 9. Click Next.
The Collection section appears. It displays a list of available collections in the data-
bases that you selected in step 8.

 10. Use the following options:
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 l Document Count/Document (%): Use this option to specify the number of doc-
uments or percentage of total records that the newly generated model schema 
would contain.

 l Deep Search: Use this option to specify whether the deep search algorithm is 
used to retrieve the right samples for schema generation.

 l Sampling: Use the Sequence or Random sampling methods to sample records in 
the selected collections. Sampling enables you to retrieve right estimates for 
accurate collection schema generation.

 11. Under Available Collections, select the collections that you want to reverse engineer. 
Then, click .

This moves the selected collections under Selected Collections.

 12. Click Next.
The Option Set section appears. It displays the default option set. You can either use 
the default  or a custom option set.
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 13. Click Next.
The Detail Options section appears. Set up appropriate options based on your require-
ment.



31

 14. Click OK.
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The reverse engineering process starts.

Once the process is complete, based on your selections, a schema is generated and a 
model is created.
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Forward Engineering Models

You can generate a physical database schema from a physical model using the Forward 
Engineering process. 

This topic walks you through the steps to forward engineer a MongoDB model. Similarly, 
you can forward engineer a model to your Cassandra Keyspace and Couchbase Bucket.

To forward engineer a model:

 1. Open your MongoDB model in erwin Data Modeler (DM).
Note: Ensure that you are in the Physical mode.

For example, the following image uses a MongoDB model with two collections.

 2. Click Actions > Schema.
The Forward Engineer Schema Generation Wizard appears.
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 3. Click Option Selection.
The Option Selection section displays the default option set. Clear the Drop check 
boxes and select other syntax check boxes as required.
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 4. Click Next.
The Collection Filter section appears. It displays a list of collections available in your 
model.
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 5. Select the collections that you want to forward engineer.
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 6. Click Preview to view the schema script.

Use the following options:

 l Auto Error Check: Select this option to enable auto error check by the forward 
engineering wizard.

 l Error Check ( ): Use this option to run an error check. Based on the results, 
you can correct the generated script.

 l Text Options ( ): Use this option to configure the preview text editor's look 
and feel, such as window, font, syntax color settings. For more information, 
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refer to the Forward Engineering Wizard - Preview Editor topic.

 l Save ( ): Use this option to save the generated script in the JSON or BSON 
format.

 7. Click Generate.
The forward engineering process starts. The script generates your physical database 
schema. You can access your database and verify the newly generated schema.

 

Comparing Changes using Complete Compare

You can compare your model with database, script, or another local model to check for dif-
ferences using the Complete Compare wizard. Based on the results, you can then resolve or 
merge differences. Thus, maintaining a consistent model and database. 

This topic walks you through the steps to compare a MongoDB model with database. Sim-
ilarly, you can compare your Cassandra and Couchbase models.

To compare models with database:

 1. Open your MongoDB model in erwin Data Modeler (DM).
Note: Ensure that you are in the Physical mode.
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For example, the following image uses a MongoDB model with two collections.

 2. Click Actions > Complete Compare.
By default, the Complete Compare wizard assigns the open model as the Left Model. 
Hence, the Right Model section appears.
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 3. Click Database/Script.
By default, the Allow Demand Loading option is selected. 

 4. Click Load.
The New Model dialog box appears. This starts the reverse engineering process to pull 
a model from the database to compare.
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 5. Ensure that the Database is set to the correct one. In this case, MongoDB. Then, click 
Next.
The Reverse Engineer Process Wizard appears.
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 6. Click Database. Then, click Next.
The Connection section appears. Use this section to connect to the database from 
which you want to reverse engineer the model.

 7. After connection is established, click Next. 
The Database section appears. It displays a list of available databases.
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 8. Under Available Databases, select the databases that you want to reverse engineer. 
Then, click .
This moves the selected databases under Selected Databases.
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 9. Click Next and in the Collection section, click . 
This selects all the available collections. Also, ensure that the Document Coun-
t/Document % is not set to zero (0).
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 10. Click Next and in the Option Set section, keep the default configuration.

 11. Click Next and in the Detail Options section, keep the default configuration.

 12. Click OK.
The reverse engineering process starts. Once the process is complete, the Right Model 
is set to the one that you reverse engineered.
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 13. Click Next and in the Type Selection section, select the appropriate options.
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For example, the following image shows the default options.

 14. Click Next and in the Left Object Selection section, select the appropriate options.
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For example, the following image shows the default options.

 15. Click Next and in the Right Object Selection section, select the appropriate options.
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For example, the following image shows the default options.

 16. Click Compare.
The comparison process runs, and the Resolve Differences dialog box appears. It dis-
plays the differences between your model and database.
For example, the following image shows that the Rating collection is available in your 
model but not in the database.
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Select the Rating collection and click . This will move the Rating collection to the 
right model (from the database). Similarly, resolve other differences.

 17. As differences were moved to the right model, click .
This launches the Forward Engineering Alter Script Generation Wizard.
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 18. Click Option Selection and clear all the Drop check boxes.

 19. Click Collection Filter and select or verify the collections to be included on the for-
ward engineering script.
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 20. Click Preview to view and verify the alter script.

 21. Click Generate and connect to your MongoDB database.
The forward engineering process starts. The script generates your physical database 
schema. You can access your database and verify the newly generated schema.

 22. Click OK. Then click Finish.
This closes the Resolve Differences dialog box and displays the Complete Compare wiz-
ard.

 23. Click Close.
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JSON and AVRO Support

erwin Data Modeler (DM) now includes modeling support for JSON and AVRO file formats. 
The following table lists the supported objects and data types for each format:

File 
Format

Objects Data Types

JSON JSON Objects

Fields

Relationships

Object

Array

Integer

Null

String

Number

Boolean
AVRO Records

Fields

Relationships

Array

Boolean

Union

Map

int

Double

Object

String

Byte

enum

Fixed

Long

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/JSON_Support_Summary.html
https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Avro_Support_Summary.html
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Similar to relational or NoSQL databases, JSON and AVRO as target databases support:

Reverse engineering models from scripts

Forward engineering models

 

Reverse Engineering Models - JSON and AVRO

You can create a data model from JSON and AVRO scripts using the Reverse Engineering pro-
cess.

Note: For reverse engineering German language JSON scripts, ensure the script Encoding is 
set to Convert to ANSI.

This topic walks you through the steps to reverse engineer a JSON model from a script file. 
Similarly, you can reverse engineer a model from your AVRO script file.

To reverse engineer a model:

 1. In erwin Data Modeler (DM), click Actions > Reverse Engineer.
The New Model screen appears.

 2. Click Logical/Physical and set Database to JSON.

 3. Click Next.
The Reverse Engineer Process Wizard appears.
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 4. Select Json Data or Schema File format option. Then, click Browse and select one or 
multiple script files.

 5. Click Next.
The Detail Options section appears. Set up appropriate options based on your require-
ment.
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 6. Click OK.
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The reverse engineering process starts.

Once the process is complete, based on your selections, a schema is generated, and a 
model is created.



59

Forward Engineering Models - JSON and AVRO 

You can generate a physical  schema  from a physical model using the Forward Engineering 
process and then, save it in the JSON and AVRO file formats. 

This topic walks you through the steps to forward engineer a JSON model. Similarly, you can 
forward engineer an AVRO model.

To forward engineer a model:

 1. Open your JSON model in erwin Data Modeler (DM).
Note: Ensure that you are in the Physical mode.

For example, the following image uses a JSON model with 16 tables.

 2. Click Actions > Schema.
The Forward Engineer Schema Generation Wizard appears.
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 3. Click Option Selection.
The Option Selection section displays the default option set. Select appropriate syntax 
options.
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 4. Click Next.
The Table Filter section appears. It displays a list of tables (JSON objects) available in 
your model.
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 5. Select the tables (JSON objects) that you want to forward engineer.
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 6. Click Preview to view the schema script.

Use the following options:

 l Auto Error Check: Select this option to enable auto error check by the forward 
engineering wizard.

 l Error Check ( ): Use this option to run an error check. Based on the results, 
you can correct the generated script.

 l Text Options ( ): Use this option to configure the preview text editor's look 
and feel, such as window, font, syntax color settings. For more information, 
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refer to the Forward Engineering Wizard - Preview Editor topic.

 l Save ( ): Use this option to save the generated script.

 7. Click Generate.
The following screen appears.

 8. Use the following options:

Set Path: Use this option to set the location to save the script file.

Generate Multiple Files: By default, a single script file is created. Select this 
option to save the script into multiple files by objects.

File Name Prefix: Select this option to add a script file name. Enter a file name. 
If this option is not selected, the script file is saved with a default name (Erwin_
FE_Script.json).

 9. Click Save.
Your script file is saved at the configured location. You can open it in any text editor 
and verify.
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Oracle Support Summary

erwin Data Modeler (DM) now supports Oracle 12c R2, 18c, 19c, and 21c as target data-
bases. This implementation supports the following objects:

Cluster

Column

Comment

Context

Database

Database Link

Directory

Disk Group

Function

Index Editor for Clusters

Index Editor for Materialized Views

Index Editor for Tables

Library

Materialized Views

Materialized View Log

Package

Package Body

Pre and Post Scripts

Rollback Segment

Sequence

Stored Procedure

Synonym

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Oracle_Support_Summary.html
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Table

Tablespace

Tablespace Group

Trigger

Views

The following table lists the supported data types:

Numeric String Literals Date and Time Other
 l BINARY_

DOUBLE

 l BINARY_
FLOAT

 l DEC

 l DEC()

 l DEC(,)

 l DECIMAL

 l DECIMAL()

 l DECIMAL(,)

 l DOUBLE 
PRECISION

 l REAL

 l FLOAT

 l FLOAT()

 l INT

 l INTEGER

 l NUMBER

 l CHAR

 l CHAR()

 l CHARVARYING()

 l CHARACTER

 l CHARACTER()

 l CHARACTERVARYING
()

 l CLOB

 l DBURITYPE

 l URITYPE

 l HTTPURITYPE

 l JSON

 l JSON()

 l LONG

 l NATIONAL CHAR

 l NATIONAL CHAR 
VARYING()

 l NATIONAL CHAR()

 l DATE

 l INTERVAL 
DAY TO 
SECOND

 l INTERVAL 
YEAR TO 
MONTH

 l TIMESTAMP

 l TIMESTAMP 
WITH LOCAL 
TIMEZONE

 l TIMESTAMP 
WITH 
TIMEZONE

 l TIMESTAMP
()

 l TIMESTAMP
() WITH 
LOCAL 
TIMEZONE

 l TIMESTAMP
() WITH 

 l JSON*
 l ANYDATA

 l ANYDATASET

 l ANYTYPE

 l BFILE

 l BLOB

 l LONGRAW

 l ORDAUDIO

 l ORDDICOM

 l ORDDOC

 l ORDIMAGE

 l ORDVIDEO

 l RAW()

 l SDO_GEOMETRY

 l SDO_GEORASTER

 l SI_AVERAGECOLOR

 l SI_COLOR
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 l NUMBER()

 l NUMBER(,)

 l NUMERIC

 l NUMERIC()

 l NUMERIC
(,)

 l ROWID

 l SMALLINT

 l NATIONAL 
CHARACTER

 l NATIONAL 
CHARACTER 
VARYING()

 l NATIONAL 
CHARACTER()

 l NCHAR

 l NCHAR VARYING()

 l NCHAR()

 l NCLOB

 l NVARCHAR2()

 l UROWID

 l UROWID()

 l VARCHAR()

 l VARCHAR2()

 l XDBURITYPE

 l XMLTYPE

TIMEZONE  l SI_
COLORHISTOGRAM

 l SI_FEATURELIST

 l SI_
POSITIONALCOLOR

 l SI_STILLIMAGE

 l SI_TEXTURE                 

*This datatype is supported only for Oracle 21c.
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Microsoft SQL Server Support

Support for Microsoft SQL Server 2019 as a target database has been enhanced to imple-
ment the following objects:

External Library

External Language

External Data Source

External File Format

External Table

Statistics

For detailed information on supported objects and data types, refer SQL Server support sum-
mary.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/SQL_Server_Support_Summary.html
https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/SQL_Server_Support_Summary.html
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Microsoft Azure SQL Server Support

Microsoft Azure SQL support in erwin DM has been revamped. It is now supported on top of 
Microsoft SQL Server to leverage common functionality. On the New Model and Target Data-
base dialog boxes, you can find Azure under SQL Server Version drop-down list.

The following table lists the supported objects:

Supported Objects
 l Always Encrypted 

Keys

 l Application Roles

 l Assemblies*

 l Asymmetric Keys

 l Certificates

 l Credentials*

 l Database Roles

 l Databases

 l Database Triggers

 l External Data 

 l Resource Pools*

 l Schemas

 l Sequences

 l Server Audits*

 l Server Audit Spe-
cification*

 l Statistics

 l Stored Procedures

 l Symmetric Keys

 l Spatial Indexes (Table)

 l Synonyms
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Source

 l External File 
Format*

 l External Library*

 l External Table

 l Full-Text Catalogs

 l Full-Text Indexes 
(Table)

 l Full-Text Stoplists

 l Functions

 l Logins

 l Partition Func-
tions

 l Partition Schemes

 l Tables

 l ColumnStore Indexes 
(Table)

 l XML Indexes (Table)

 l Indexes (Table)

 l Table Triggers

 l Triggers

 l User Ids

 l Views

 l View Indexes

 l View Triggers

 l XML Schema Col-
lections

* These objects are supported only for Azure SQL Managed Instance.

The following table lists the supported data types:

Exact 
Numerics

Approx-
imate 
Numer-
ics

Date and 
Time

Char-
acter 
Strings

Unicode 
Char-
acter 
Strings

Binary 
Strings

Geo Types Others

 l bigin-
t

 l num-
eric

 l bit

 l smal-

 l fl-
o-
at

 l re-
al

 l date

 l dat-
etime-
offset

 l dat-
etime2

 l ch-
ar

 l va-
rc-
h-
ar

 l te-

 l nc-
har

 l nv-
arc-
har

 l nt-
ext

 l bin-
ary

 l var-
bin-
ary

 l im-
age

 l rowver-
sion

 l hier-
archyid

 l uniquei-
den-
tifier

 l
CHA-
R 
VAR-
YING

 l CHA-
RAC-
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lint

 l deci-
mal

 l small-
mon-
ey

 l int

 l tiny-
int

 l mon-
ey

 l smalld-
ate-
time

 l dat-
etime

 l time

xt  l sql_vari-
ant

 l xml

 l geo-
metry

 l geo-
graphy

TER

 l CHA-
RAC-
TER 
VAR-
YING

 l NATI-
ONA-
L 
CHA-
R 
VAR-
YING

 l NATI-
ONA-
L 
CHA-
R

 l NATI-
ONA-
L 
CHA-
RAC-
TER

 l NATI-
ONA-
L 
TEXT               
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MySQL Support

erwin Data Modeler (DM) now supports MySQL 8.x as a target database. This imple-
mentation supports the following objects:

Database

Event

Function

Function_UDF

Logfile Group

Server

Spatial Ref System

Stored Procedure

Table

Index

Table Column

Tablespace

Trigger

User ID

Validation Rule

View

View Column

The following table lists the supported data types:

Numeric String Literals Date and Time Other
 l TINYINT
 l SMALLINT
 l MEDIUMINT
 l INT, 

INTEGER

 l CHAR
 l VARCHAR
 l BINARY
 l CHAR BYTE

 l DATE
 l TIME
 l DATETIME
 l TIMESTAMP
 l YEAR 

 l Geometry Type    
 l POINT 
 l LINESTRING 
 l POLYGON 
 l MULTIPOINT 

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/MySQL_Support_Summary.html
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 l BIGINT
 l DECIMAL, 

DEC, 
NUMERIC, 
FIXED

 l FLOAT
 l DOUBLE, 

DOUBLE 
PRECISION, 
REAL

 l BIT

 l VARBINARY

 l TINYBLOB

 l BLOB

 l BLOB and 
TEXT Data 
Types

 l MEDIUMBLOB

 l LONGBLOB

 l TINYTEXT

 l TEXT

 l MEDIUMTEXT

 l LONGTEXT

 l JSON Data 
Type

 l ENUM

 l Set Data Type

 l MULTILINESTRING
 l MULTIPOLYGON 
 l GEOMETRYCOLLECTION
 l GEOMETRY                  

Note:

Refer to MySQL database documentation for detailed information on specific MySQL 
objects and properties. erwin® Data Modeler documentation for the property editors 
provides brief descriptions of the controls on each dialog box and tab, which you can 
use as a point of reference while working with database design features.

As a best practice, use the MySQL ANSI ODBC driver for Reverse Engineering from 
Database (REDB) while using erwin® Data Modeler
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Data Vault 2.0 Support

erwin Data Modeler (DM) now Data Vault 2.0 as a modeling technique across all target data-
bases. This implementation supports the following Data Vault 2.0 components by default 
through API:

Hub

Link

Satellite

Reference

PIT

Bridge

These components are available on Home tab of the ribbon.

To enable Data Vault 2.0 on your model, follow these steps:

 1. Right-click the model and click Properties.

 2. On the Model Editor > General tab, select the Data Vault 2.0 check box.
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Once enabled, Data Vault 2.0 components are available via the Model Explorer. You 
can now convert your model to a Data Vault model.

You can also create custom components and apply them to tables. However, these 
custom components do not appear on the ribbon.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Converting_Models_DataVault.html
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Productivity and UI Enhancements

Several additions and enhancements have been implemented to improve erwin Data 
Modeler's (DM) productivity and usage experience. These enhancements are:

Welcome Page

Objects Count Pane

Properties Pane

Object Browser

Normalization and Denormalization

Reverse Engineering and Forward Engineering Wizard Redesign

Improved Speed Mode

Welcome Page

The Welcome page is a starter page that helps new users to get started with erwin DM. It 
appears when you launch erwin DM and is also accessible via Help > Welcome. It contains 
shortcuts to key actions that are performed frequently, such as opening models or creating 
new ones, running reverse engineering or complete compare wizards, and connecting to the 
Mart. Apart from these, the Welcome page provides access to recently used files,  erwin DM 
Tools, Technical Support, and Help links.
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Objects Count Pane

As data models become complex and large, it becomes necessary to get a snapshot of the 
objects within models. To facilitate this, erwin DM now includes an Objects Count pane. This 
pane displays information about a selected model and a count of all the objects present in 
it. Also, it displays a snapshot of this information in the pictorial format, which you can cus-
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tomize using the Style and Pallete options. By default, this pane opens on the right-side of 
the application. You can also access it via View > Panes > Objects Count Pane.

Properties Pane

While working on data models, accessing the property editors to view or edit the model and 
its object's properties can get tedious and slow you down. To address this, erwin DM now 
includes a Properties pane. This pane enables you to view and edit the selected object's 
properties along with the model diagram, side-by-side. By default, this pane opens on the 
right-side of the application. You can also access it via View > Panes > Properties Pane on 
the ribbon.



79

Object Browser

The Object Browser is a one-stop location where you can view tables, views, materialized 
views, indexes, relationships, and the complete model's or specific table's DDL. You can 
export this information as a report in CSV, HTML, or PDF formats. To access the Object 

Browser, on the Properties pane, click  or on the ribbon, click Tools > Object Browser. 
For more information, refer to the Object Browser topic.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Object_Browser.html
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Normalization and Denormalization

The Normalization and Denormalization features enable you to define relationships in a 
NoSQL model. Normalization splits the fields in a collection into multiple collections based 
on the selected relationship type. Whereas Denormalization embeds multiple collections 
into a single collection based on the selected embedding type. To access these features, on 
the ribbon, click Actions. Then, click Normalization or Denormalization. For more inform-
ation, refer to the Defining Relationships Using Embedding Method topic.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Defining_Relationships_Using_Embedding_Method.html
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Reverse Engineering and Forward Engineering Wizard Redesign

The Reverse Engineering and Forward Engineering wizards have been redesigned for better 
arrangement of properties and ease of use. For more information, refer to the Reverse 
Engineering and Forward Engineering topics.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/set_options_for_reverse_engineer.html
https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/set_options_for_reverse_engineer.html
https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Select_Schema_Generation_Options.html
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Improved Speed Mode

The Load Diagram with speed mode option now provides another option, Load Diagram 
with entity/table view. This option improves the model load performance in case of large 
models significantly. It does so by  rendering the model in the simplest way possible, with 
only the entities or tables, and their relationships. Also, by default, it disables the PK-FK high-
light feature (Display Diagram Highlight option on Model Editor).

This option is available on Tools > Options dialog box.
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Database Connectivity

You can now connect to the following databases from erwin Data Modeler (DM) without 
using a client software.

Relational Databases:

Oracle

SQL Server

Azure SQL

Azure Synapse

MySQL

MariaDB

SAP ASE

Snowflake

NoSQL Databases:

Cassandra

Couchbase

MongoDB

To connect to these databases without a client software, use the following database con-
nection parameters:

Oracle

Instance

Specifies the JDBC instance to which you want to connect.

For a cloud-based connected, the instance name is as follows:

TNS_ADMIN=<Path of unzipped cloud wallet file>

For example, TNS_ADMIN=C:\\Users\\MyUser\\Wallet_DBTEST
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Note:Ensure that you have downloaded, saved, and unzipped the cloud wallet 
file.

Connection String

Specifies the connection string based on your JDBC instance in the following 
format:

jdbc:oracle:thin:@//<servername>:1521/

For example, JDBC:ORACLE:thin:@//localhost:1521/

For a cloud instance, the connection string is as follows:

jdbc:oracle:thin:@<dbname_priority>?

For example, jdbc:oracle:thin:@dbtest_medium?

SQL Server

Connection Type

Specifies the type of connection you want to use. Select Use Native Connection 
to connect using the API provided by the SQL Server Native client software. 
Select Use ODBC Data Source to connect using the ODBC data source that you 
have defined. Select Use JDBC Connection to connect using JDBC.

Instance

Specifies the JDBC instance to which you want to connect.

Database

Specifies the name of the database that you want to connect to.

Connection String

Specifies the connection string based on your JDBC instance and SQL Server 
database name in the following format:

jdbc:sqlserver://<servername>:1433=<SqlDBname>

For example, jdbc:sqlserver://localhost:1433

Azure SQL
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Connection Type

Specifies the type of connection you want to use. Select Use Native Connection 
to connect using the API provided by the SQL Server Native client software. 
Select Use ODBC Data to connect using the ODBC data source that you have 
defined. Select Use JDBC Connection to connect using JDBC.

Instance

Specifies the JDBC instance to which you want to connect.

Database

Specifies the name of the database that you want to connect to.

Connection String

Specifies the connection string based on your JDBC instance and SQL Server 
database name in the following format:

jdbc:sqlserver://<servername>:<port>
For example, jdbc:sqlserver://localhost:1433

Connect to Managed Instance

Specifies whether the connection should be to an Azure SQL Managed Instance. 

Azure Synapse

Connection Method

Specifies the type of connection you want to use. Select JDBC to connect using 
JDBC.

Connection String

Specifies the connection string based on your JDBC instance and Azure Synapse 
database namein the following format:

jdbc: sqlserver://<server name>.sql.azuresynapse.net:1433;

For example, jdbc:sqlserver://localhost.sql.azuresynapse.net:1433;

Database
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Specifies the name of the database that you want to connect to.

MySQL

Hostname/IP

Specifies the hostname or IP address of the server where your database is hos-
ted.

Port

Specifies the port configured for your database.

Database

Specifies the name of the database to which you want to connect.

Note: For the JDBC connection to work seamlessly, ensure that you download the 
required JDBC driver and rename it to mysql-connector-java-8.0.22.jar.

MariaDB

Connection String

Specifies the connection string in the following format:

jdbc:mariadb

Hostname/IP

Specifies the hostname or IP address of the server where your database is hos-
ted.

Port

Specifies the port configured for your database.

Database

Specifies the name of the database to which you want to connect.

Note: For the JDBC connection to work seamlessly, ensure that you download the 
required JDBC driver and rename it to mariadb-java-client-2.6.1.jar.

SAP ASE
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Connection Method

Specifies the type of connection you want to use.  Select Use JDBC Connection to 
connect using JDBC.

Server

Specifies the name of the server where the database is installed.

Database

Specifies the name of the database that you want to connect to.

Connection String

Specifies the connection string based on your JDBC instance and SAP ASE data-
base name  in the following format:

jdbc:sybase:Tds:<servername>:5000
For example, jdbc:sybase:Tds:localhost:5000

Snowflake

Connection String

Specifies the connection string based on your JDBC instance and Snowflake data-
base name. For example, jdbc:snowflake://<account_name>.s-
nowflakecomputing.com/

Connection String is a mandatory parameter.

Database

Specifies the name of the database that you want to connect to.

Database is a mandatory parameter.

Warehouse

Specifies the name of the warehouse that you want to connect to.

Warehouse is a mandatory parameter.

Role

Specifies the role that you want to use to connect to the database.

Role is a mandatory parameter.
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Schema

Specifies the name of the schema that you want to connect to.

Cassandra

Connection Method

Specifies the type of connection you want to use. Select Direct to connect to 
connect to your cluster directly. Select Connection String to connect to your 
cluster using a connection string.

Hostname/IP

Specifies the hostname or IP address of the server where your cluster is hosted.

Port

Specifies the port configured for your cluster.

Connection String

Specifies the path to the secure connect ZIP file in the following format:

C:\<file name>.zip

For example, C:\TempCass\secure-connect-testdb.zip

Couchbase

Connection Method

Specifies the type of connection you want to use. Select Direct to connect to 
connect to your bucket directly. Select Connection String to connect to your 
bucket using a connection string.

Hostname/IP

Specifies the hostname or IP address of the server where your bucket is hosted.

Port

Specifies the port configured for your bucket.
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Bucket

Specifies the name of the bucket to which you want to connect.

SSL Certificate Path

Specifies the path to the SSL certificate, if you have one. You can leave this field 
blank.

Connection String

Specifies the connection string in the following format:

couchbases://<database server>/<bucket>?ssl=no_verify

For example, couchbases://server1.dp.cloud.couchbase.com/testbucket?ssl=no_
verify

MongoDB

Connection Method

Specifies the type of connection you want to use. Select Direct to connect to 
connect to your database directly. Select Connection String to connect to your 
database using a connection string.

Hostname/IP

Specifies the hostname or IP address of the server where your database is hos-
ted.

Port

Specifies the port configured for your database.

Database

Specifies the name of the database to which you want to connect.

Connection String

Specifies the connection string in the following format:
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mongodb://[username:password@]host1[:port1][,...hostN[:portN]][/[defaultau-
thdb][?options]]

For example, mongodb+srv://myusername:****
@cluster0.v7gra.mongodb.net/test?retryWrites=true&w=majority

For more information on database connection parameters, refer to the Database Con-
nection Parameters topic.

https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Database_Connection_Parameters.html
https://erwin.com/bookshelf/public_html/2021R1/Content/User Guides/erwin Help/Database_Connection_Parameters.html
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